summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..c7aacee
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,18 @@
+{ pkgs ? import <nixpkgs> { } }:
+
+let
+ manifest = (pkgs.lib.importTOML ./Cargo.toml).package;
+in pkgs.rustPlatform.buildRustPackage rec {
+ pname = manifest.name;
+ version = manifest.version;
+
+ cargoLock.lockFile = ./Cargo.lock;
+ src = pkgs.lib.cleanSource ./.;
+
+ meta = with pkgs.lib; {
+ description = "A fast line-oriented regex search tool, similar to ag and ack";
+ homepage = "https://github.com/BurntSushi/ripgrep";
+ license = licenses.gpl3;
+ maintainers = [ "jptrzy" ];
+ };
+}
Software created with 💖