summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJakub Trzeciak <jp3@jptrzy.xyz>2024-02-10 20:56:31 +0100
committerJakub Trzeciak <jp3@jptrzy.xyz>2024-02-10 20:56:31 +0100
commitf0c230f38579f04191c3a5b4b9d56a70876cfb00 (patch)
treef571bb3c72a827a51ee18142978bb541c0e1d558 /flake.nix
parentfcf044db0618c1901bc3c46b238353c95491cbfc (diff)
downloadogg-tagger-f0c230f38579f04191c3a5b4b9d56a70876cfb00.tar.gz
ogg-tagger-f0c230f38579f04191c3a5b4b9d56a70876cfb00.tar.bz2
ogg-tagger-f0c230f38579f04191c3a5b4b9d56a70876cfb00.zip
add flake dev env
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9a709aa
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,27 @@
+{
+ description = "A Rust project with LSP";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.05";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs = { self, nixpkgs, flake-utils, ... }@inputs:
+ flake-utils.lib.eachDefaultSystem (system:
+ let
+ pkgs = import nixpkgs { inherit system; };
+ in
+ {
+ devShell = pkgs.mkShell {
+ buildInputs = with pkgs; [
+ rustc
+ cargo
+ rust-analyzer
+ ];
+
+ shellHook = ''
+ echo "Rust and Rust Analyzer are ready!"
+ '';
+ };
+ });
+}
Software created with 💖