summaryrefslogtreecommitdiff
path: root/overlays/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
new file mode 100644
index 0000000..a13ea3c
--- /dev/null
+++ b/overlays/default.nix
@@ -0,0 +1,23 @@
+# This file defines overlays
+{inputs, ...}: {
+ # This one brings our custom packages from the 'pkgs' directory
+ additions = final: _prev: import ../pkgs {pkgs = final;};
+
+ # This one contains whatever you want to overlay
+ # You can change versions, add patches, set compilation flags, anything really.
+ # https://nixos.wiki/wiki/Overlays
+ modifications = final: prev: {
+ # example = prev.example.overrideAttrs (oldAttrs: rec {
+ # ...
+ # });
+ };
+
+ # When applied, the unstable nixpkgs set (declared in the flake inputs) will
+ # be accessible through 'pkgs.unstable'
+ unstable-packages = final: _prev: {
+ unstable = import inputs.nixpkgs-unstable {
+ system = final.system;
+ config.allowUnfree = true;
+ };
+ };
+}
Software created with 💖