summaryrefslogtreecommitdiff
path: root/overlays/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/default.nix')
-rw-r--r--overlays/default.nix21
1 files changed, 20 insertions, 1 deletions
diff --git a/overlays/default.nix b/overlays/default.nix
index a13ea3c..3037a94 100644
--- a/overlays/default.nix
+++ b/overlays/default.nix
@@ -1,5 +1,12 @@
# This file defines overlays
-{inputs, ...}: {
+{ pkgs, username, inputs, ... }: let
+ dmenu-src = builtins.fetchTarball "https://git.jptrzy.xyz/dmenu/snapshot/master.tar.gz";
+ #dwm-src = builtins.fetchTarball "https://git.jptrzy.xyz/dwm/snapshot/master.tar.gz";
+ dwmblocks-src = builtins.fetchTarball "https://git.jptrzy.xyz/dwmblocks/snapshot/master.tar.gz";
+ sent-src = builtins.fetchTarball "https://git.jptrzy.xyz/sent/snapshot/master.tar.gz";
+ slock-src = builtins.fetchTarball "https://git.jptrzy.xyz/slock/snapshot/master.tar.gz";
+ dwm-src = /home/${username}/.local/src/dwm;
+in {
# This one brings our custom packages from the 'pkgs' directory
additions = final: _prev: import ../pkgs {pkgs = final;};
@@ -10,6 +17,18 @@
# example = prev.example.overrideAttrs (oldAttrs: rec {
# ...
# });
+ dmenu = prev.dmenu.overrideAttrs (old: { src = dmenu-src; });
+ dwm = prev.dwm.overrideAttrs (old: { src = dwm-src; });
+ dwmblocks = prev.dwmblocks.overrideAttrs (old: { src = dwmblocks-src; });
+ sent = prev.dwm.overrideAttrs (old: { src = sent-src; });
+ slock = prev.slock.overrideAttrs (old: {
+ src = slock-src;
+ buildInputs = with pkgs; [
+ xorg.libXinerama
+ xorg.libXft
+ imlib2
+ ] ++ old.buildInputs;
+ });
};
# When applied, the unstable nixpkgs set (declared in the flake inputs) will
Software created with 💖