summaryrefslogtreecommitdiff
path: root/home-manager/sh/dmenu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/sh/dmenu.nix')
-rw-r--r--home-manager/sh/dmenu.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/home-manager/sh/dmenu.nix b/home-manager/sh/dmenu.nix
new file mode 100644
index 0000000..40c6c77
--- /dev/null
+++ b/home-manager/sh/dmenu.nix
@@ -0,0 +1,15 @@
+{ pkgs }:
+
+let
+ mpv-camera = pkgs.writeShellScriptBin "mpv-camera" ''
+ ${pkgs.mpv}/bin/mpv /dev/video0 \
+ osc=no --input-vo-keyboard=no --player-operation-mode=pseudo-gui \
+ no-cache --untimed --no-demuxer-thread \
+ --video-sync=audio --vd-lavc-threads=1 --vf=hflip
+ '';
+in pkgs.symlinkJoin {
+ name = "mpv";
+ paths = [
+ mpv-camera
+ ];
+}
Software created with 💖