summaryrefslogtreecommitdiff
path: root/home-manager/sh/colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/sh/colors.nix')
-rw-r--r--home-manager/sh/colors.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/home-manager/sh/colors.nix b/home-manager/sh/colors.nix
new file mode 100644
index 0000000..f25a02f
--- /dev/null
+++ b/home-manager/sh/colors.nix
@@ -0,0 +1,18 @@
+{ pkgs }:
+
+pkgs.writeShellScriptBin "colors" ''
+ space=" "
+
+ output=""
+
+ for l in $(printf "40\n100"); do
+
+ for i in $(seq $l $((l + 9))); do
+ output="$output\033[0;''${i}m$space"
+ done
+
+ output="$output\033[0m\n"
+ done
+
+ printf "$output"
+''
Software created with 💖