summaryrefslogtreecommitdiff
path: root/home-manager/firefox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/firefox.nix')
-rw-r--r--home-manager/firefox.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/home-manager/firefox.nix b/home-manager/firefox.nix
index 820354c..0a3b922 100644
--- a/home-manager/firefox.nix
+++ b/home-manager/firefox.nix
@@ -1,6 +1,7 @@
{ config, pkgs, theme, ... }:
let
+ firefox-i2p = pkgs.writeShellScriptBin "firefox-i2p" ''firefox -p i2p'';
firefox-work = pkgs.writeShellScriptBin "firefox-work" ''firefox -p work'';
# Show all packages - `nix flake show "gitlab:rycee/nur-expressions?dir=pkgs/firefox-addons"`
@@ -64,6 +65,25 @@ in {
};
profiles = {
+ i2p = {
+ isDefault = false; id = 2;
+ name = "i2p";
+
+ settings = {
+ "javascript.enabled" = false;
+ "keyword.enabled" = true;
+
+ "network.proxy.type" = 1;
+ "network.proxy.share_proxy_settings" = true;
+
+ "network.proxy.http" = "127.0.0.1";
+ "network.proxy.http_port" = 4444;
+
+ "network.proxy.ssl" = "127.0.0.1";
+ "network.proxy.ssl_port" = 4444;
+ };
+ };
+
work = {
isDefault = false; id = 1;
name = "work";
@@ -83,6 +103,7 @@ in {
};
home.packages = [
+ firefox-i2p
firefox-work
];
}
Software created with 💖