summaryrefslogtreecommitdiff
path: root/home-manager/.flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/.flake.nix')
-rw-r--r--home-manager/.flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/home-manager/.flake.nix b/home-manager/.flake.nix
new file mode 100644
index 0000000..b3ad2fa
--- /dev/null
+++ b/home-manager/.flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "Home Manager configuration of jp3";
+
+ inputs = {
+ # Specify the source of Home Manager and Nixpkgs.
+ nixpkgs.url = "github:nixos/nixpkgs/release-23.05";
+ home-manager = {
+ url = "github:nix-community/home-manager/release-23.05";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+ };
+
+ outputs = { nixpkgs, home-manager, ... }:
+ let
+ system = "x86_64-linux";
+ pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ homeConfigurations."jp3" = home-manager.lib.homeManagerConfiguration {
+ inherit pkgs;
+
+ # Specify your home configuration modules here, for example,
+ # the path to your home.nix.
+ modules = [ ./home.nix ];
+
+ # Optionally use extraSpecialArgs
+ # to pass through arguments to home.nix
+ };
+ };
+}
Software created with 💖