summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..344a8a1
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,58 @@
+{
+ description = "Jptrzy's nixos config";
+
+ inputs = {
+ # Nixpkgs
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-23.05";
+ nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
+
+ # Home manager
+ home-manager.url = "github:nix-community/home-manager/release-23.05";
+ home-manager.inputs.nixpkgs.follows = "nixpkgs";
+
+ # Nix Colors
+ nix-colors.url = "github:misterio77/nix-colors";
+ };
+
+ outputs = {
+ self,
+ nixpkgs,
+ home-manager,
+ ...
+ } @ inputs: let
+ inherit (self) outputs;
+
+ username = "jp3";
+ hostname = "x270";
+
+ system = "x86_64-linux";
+
+ pkgs = import nixpkgs {
+ inherit system;
+ };
+ lib = nixpkgs.lib;
+ in {
+ #overlays = import ./overlays {inherit inputs;};
+
+ # NixOS configuration entrypoint
+ # Available through 'nixos-rebuild --flake .#your-hostname'
+ nixosConfigurations = {
+ ${hostname} = nixpkgs.lib.nixosSystem {
+ specialArgs = { inherit username hostname system inputs outputs; };
+ modules = [
+ ./nixos/configuration.nix
+
+ home-manager.nixosModules.home-manager {
+ home-manager.useGlobalPkgs = true;
+ home-manager.useUserPackages = true;
+ home-manager.users.${username} = {
+ imports = [ ./home-manager/home.nix ];
+ };
+ home-manager.extraSpecialArgs = { inherit username; };
+ }
+ ];
+ };
+ };
+
+ };
+}
Software created with 💖