summaryrefslogtreecommitdiff
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/configuration.nix b/configuration.nix
index df11316..bf3d2c7 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -5,16 +5,18 @@
{ config, pkgs, ... }:
let
+ user = "jp3";
+
home-manager = builtins.fetchTarball "https://github.com/nix-community/home-manager/archive/release-23.05.tar.gz";
dmenu-src = builtins.fetchTarball "https://git.jptrzy.xyz/dmenu/snapshot/master.tar.gz";
- dwm-src = builtins.fetchTarball "https://git.jptrzy.xyz/dwm/snapshot/master.tar.gz";
+ #dwm-src = builtins.fetchTarball "https://git.jptrzy.xyz/dwm/snapshot/master.tar.gz";
dwmblocks-src = builtins.fetchTarball "https://git.jptrzy.xyz/dwmblocks/snapshot/master.tar.gz";
neo-comic-mono-font = builtins.fetchTarball "https://git.jptrzy.xyz/neo-comic-mono-font/snapshot/master.tar.gz";
sent-src = builtins.fetchTarball "https://git.jptrzy.xyz/sent/snapshot/master.tar.gz";
slock-src = builtins.fetchTarball "https://git.jptrzy.xyz/slock/snapshot/master.tar.gz";
- user = "jp3";
+ dwm-src = /home/${user}/.local/src/dwm;
in {
# NixOS Specific
@@ -53,7 +55,7 @@ in {
home-manager.users."${user}" = import ./home-manager/home.nix {
inherit user config pkgs;
- inherit (pkgs.nixpkgs) lib;
+ inherit (pkgs) lib;
};
security.pam.services."${user}".enableGnomeKeyring = true;
security.wrappers = {
@@ -135,7 +137,9 @@ in {
vaapiIntel # LIBVA_DRIVER_NAME=i965 (older but works better for Firefox/Chromium)
vaapiVdpau
libvdpau-va-gl
+ libGL
];
+ setLdLibraryPath = true;
};
};
@@ -322,6 +326,7 @@ in {
monero-gui
sent
xautolock
+ fragments # Torrent client
# Gnome Apps without Gnome
gnome.adwaita-icon-theme libsecret gnome.seahorse
@@ -333,6 +338,7 @@ in {
angband
nethack
openttd
+ dolphin-emu
];
}
Software created with 💖