summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorJakub Trzeciak <jptrzy@gmail.com>2023-10-19 10:06:57 +0200
committerJakub Trzeciak <jptrzy@gmail.com>2023-10-19 10:06:57 +0200
commit8d36da17cab32530f4a0ec79432b1b5a7f744d90 (patch)
tree00d3c57955a49e3a1247d39d6421447429d1501c /flake.nix
parent5296090c63384e1c4ba3de95dd04763026da7b5c (diff)
downloadnixos-8d36da17cab32530f4a0ec79432b1b5a7f744d90.tar.gz
nixos-8d36da17cab32530f4a0ec79432b1b5a7f744d90.tar.bz2
nixos-8d36da17cab32530f4a0ec79432b1b5a7f744d90.zip
Overlays and more
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index d79d2b6..5381a8f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,12 +28,19 @@
system = "x86_64-linux";
- pkgs = import nixpkgs {
- inherit system;
- };
- lib = nixpkgs.lib;
+ #pkgs = import nixpkgs {
+ # inherit system;
+ #};
+ #lib = nixpkgs.lib;
in {
- #overlays = import ./overlays {inherit inputs;};
+ # Your custom packages
+ # Acessible through 'nix build', 'nix shell', etc
+ packages = (
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in import ./pkgs { inherit pkgs; });
+
+ # Your custom packages and modifications, exported as overlays
+ overlays = import ./overlays {inherit inputs;};
# NixOS configuration entrypoint
# Available through 'nixos-rebuild --flake .#your-hostname'
Software created with 💖