summaryrefslogtreecommitdiff
path: root/pkgs/modrinth-app/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/modrinth-app/default.nix')
-rw-r--r--pkgs/modrinth-app/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/modrinth-app/default.nix b/pkgs/modrinth-app/default.nix
new file mode 100644
index 0000000..3ea1d6e
--- /dev/null
+++ b/pkgs/modrinth-app/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, lib, appimage-run, fetchurl, writeShellScriptBin, libthai }:
+
+stdenv.mkDerivation rec {
+ pname = "modrinth-app";
+ version = "0.6.0";
+
+ buildInputs = [
+ libthai
+ ];
+
+ unpackPhase = "true";
+ srcs = [];
+
+ postInstall = let
+ src = fetchurl {
+ url = "https://launcher-files.modrinth.com/versions/${version}/linux/${pname}_${version}_amd64.AppImage";
+ sha256 = "sha256-7BIoKqFXe9gqSfQXk8BUEQT5Fx7S8tXZ9cBl+WBjMGc=";
+ };
+ in ''
+ mkdir -p $out/bin
+ echo "${appimage-run}/bin/appimage-run ${src}" > $out/bin/modrinth-app
+ chmod +x $out/bin/modrinth-app
+ '';
+
+ meta = with lib; {
+ description = "Modrinth minecraft launcher";
+ homepage = "https://modrinth.com/app";
+ #license = licenses.gpl3Only;
+ #maintainers = with maintainers; [ elnudev ];
+ platforms = [ "x86_64-linux" ];
+ sourceProvenance = [ lib.sourceTypes.binaryNativeCode ];
+ };
+}
Software created with 💖