summaryrefslogtreecommitdiff
path: root/home-manager/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/home.nix')
-rw-r--r--home-manager/home.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/home-manager/home.nix b/home-manager/home.nix
index d185fa3..f57bd22 100644
--- a/home-manager/home.nix
+++ b/home-manager/home.nix
@@ -1,4 +1,4 @@
-{ username, nix-colors, config, pkgs, lib, ... }:
+{ inputs, username, nix-colors, config, pkgs, lib, ... }:
let
nvim-spell-pl-utf8-dict = builtins.fetchurl {
url = "http://ftp.vim.org/vim/runtime/spell/pl.utf-8.spl";
@@ -13,6 +13,11 @@ let
schemeFromYaml = import ./schemeFromYAML.nix;
in {
+ nix.settings = {
+ trusted-substituters = ["https://cache.garnix.io"];
+ trusted-public-keys = ["cache.garnix.io:CTFPyKSLcx5RMJKfLo5EEPUObbA78b0YQ2DTCJXqr9g="];
+ };
+
imports = [
nix-colors.homeManagerModules.default
./addons/firefox.nix
@@ -48,10 +53,10 @@ in {
(import ./sh/mpv.nix {inherit pkgs; })
(import ./sh/fuzzel.nix {inherit pkgs; })
- ### Games ###
- modrinth-app
+ modrinth-app
];
+
nixpkgs.config.packageOverrides = pkgs: {
nur = import (builtins.fetchTarball "https://github.com/nix-community/NUR/archive/master.tar.gz") {
inherit pkgs;
Software created with 💖