summaryrefslogtreecommitdiff
path: root/home-manager/addons/sway.nix
diff options
context:
space:
mode:
Diffstat (limited to 'home-manager/addons/sway.nix')
-rw-r--r--home-manager/addons/sway.nix59
1 files changed, 53 insertions, 6 deletions
diff --git a/home-manager/addons/sway.nix b/home-manager/addons/sway.nix
index e4b3544..2546837 100644
--- a/home-manager/addons/sway.nix
+++ b/home-manager/addons/sway.nix
@@ -1,6 +1,32 @@
{ config, pkgs, theme, ... }: {
home.file = {
".config/sway/config" = (import ./sway-config.nix {inherit pkgs;});
+
+ ".config/foot/foot.ini".text = ''
+ font=Neo Comic Mono:size=16
+
+ [colors]
+ background=${config.colorScheme.colors.base00}
+ foreground=${config.colorScheme.colors.base05}
+
+ regular0=${config.colorScheme.colors.base01}
+ regular1=${config.colorScheme.colors.base08}
+ regular2=${config.colorScheme.colors.base0B}
+ regular3=${config.colorScheme.colors.base0A}
+ regular4=${config.colorScheme.colors.base0D}
+ regular5=${config.colorScheme.colors.base0E}
+ regular6=${config.colorScheme.colors.base0C}
+ regular7=${config.colorScheme.colors.base06}
+
+ bright0=${config.colorScheme.colors.base02}
+ bright1=${config.colorScheme.colors.base12}
+ bright2=${config.colorScheme.colors.base14}
+ bright3=${config.colorScheme.colors.base13}
+ bright4=${config.colorScheme.colors.base16}
+ bright5=${config.colorScheme.colors.base17}
+ bright6=${config.colorScheme.colors.base15}
+ bright7=${config.colorScheme.colors.base07}
+ '';
};
services = {
@@ -8,18 +34,39 @@
kanshi = {
enable = true;
- };
- };
- programs = {
- foot = {
- enable = true;
- server.enable = true;
+ extraConfig = ''
+ profile {
+ output eDP-1 disable
+ output DP-1 enable mode 1920x1080 position 0,0
+ output HDMI-A-2 enable mode 1920x1080 position 1920,0
+ }
+
+ profile {
+ output eDP-1 disable
+ output DP-5 enable mode 1920x1080 position 0,0
+ output DP-3 enable mode 1920x1080 position 1920,0
+ }
+
+ profile {
+ output eDP-1 enable mode 1920x1080
+ }
+ '';
};
};
+ #programs = {
+ # foot = {
+ # enable = true;
+ # server.enable = true;
+ # };
+ #};
home.packages = with pkgs; [
wl-clipboard
+
+ pass-wayland
+
+ fuzzel
];
}
Software created with 💖