summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index d79d2b6..5381a8f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,12 +28,19 @@
system = "x86_64-linux";
- pkgs = import nixpkgs {
- inherit system;
- };
- lib = nixpkgs.lib;
+ #pkgs = import nixpkgs {
+ # inherit system;
+ #};
+ #lib = nixpkgs.lib;
in {
- #overlays = import ./overlays {inherit inputs;};
+ # Your custom packages
+ # Acessible through 'nix build', 'nix shell', etc
+ packages = (
+ let pkgs = nixpkgs.legacyPackages.${system};
+ in import ./pkgs { inherit pkgs; });
+
+ # Your custom packages and modifications, exported as overlays
+ overlays = import ./overlays {inherit inputs;};
# NixOS configuration entrypoint
# Available through 'nixos-rebuild --flake .#your-hostname'
Software created with 💖