summaryrefslogtreecommitdiff
path: root/home-manager/dmenu-bluetooth.nix
diff options
context:
space:
mode:
authorJakub Trzeciak <jptrzy@gmail.com>2023-09-17 12:23:11 +0200
committerJakub Trzeciak <jptrzy@gmail.com>2023-09-17 12:23:11 +0200
commit5ce3d790fbf92e2b0a29901db114517fe02ff40d (patch)
tree4235695e53f2cc09d1b67b9582c482a3dbd417e4 /home-manager/dmenu-bluetooth.nix
parentd59110695ea72e086d534c9e2b7cf54a3ea07002 (diff)
downloadnixos-5ce3d790fbf92e2b0a29901db114517fe02ff40d.tar.gz
nixos-5ce3d790fbf92e2b0a29901db114517fe02ff40d.tar.bz2
nixos-5ce3d790fbf92e2b0a29901db114517fe02ff40d.zip
dmenu-bluetooth
Diffstat (limited to 'home-manager/dmenu-bluetooth.nix')
-rw-r--r--home-manager/dmenu-bluetooth.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/home-manager/dmenu-bluetooth.nix b/home-manager/dmenu-bluetooth.nix
new file mode 100644
index 0000000..73af067
--- /dev/null
+++ b/home-manager/dmenu-bluetooth.nix
@@ -0,0 +1,19 @@
+{ stdenv, fetchurl, dmenu }:
+
+let
+ dmenu-bluetooth = fetchurl {
+ url = "https://raw.githubusercontent.com/Layerex/dmenu-bluetooth/e6fbfbdb1c968b591523ed7de932cde10628876e/dmenu-bluetooth";
+ sha256 = "sha256-N7pCl9kLvJ2+ljczOWhaNJPLej62JWrF+uWlLp+l6lE=";
+ };
+in stdenv.mkDerivation rec {
+ pname = "dmenu-bluetooth";
+ version = "0.0.1";
+
+ unpackPhase = "true";
+ srcs = [];
+
+ postInstall = ''
+ mkdir -p $out/bin
+ install ${dmenu-bluetooth} $out/bin/dmenu-bluetooth
+ '';
+}
Software created with 💖